Discussion in 'EQ2Bot (Freeware)' started by SymmetryS, Sep 15, 2013.

  1. SymmetryS

    SymmetryS Active Member

    I'm relatively certain this is happening because I'm not fully up to speed with Windows 8 yet. I'm getting "rror Working copy 'C:\Program...\Eq2Bot' locked and Attemt to write a readonly database. I've turned off the read only attributes for the folders and subfolders, but I keep getting this error.

    Does anyone know how to make this work?


    Of course, as soon as I asked for help, I figured it out. Sorry. NooB is OH so appropriate for my tag.
    Last edited: Sep 15, 2013
  2. xalpus

    xalpus New Member

    any chance you could post what you did to fix it i'm having the same issue
  3. contra138

    contra138 Member

    Don't mean to necro this post but this is the same problem I am having and I can't seem to fix it.. any help would be appreciated!!

    I am also using windows 8.

    when i try to update it it says:
    Working copy 'C:\Program Files (x86)\InnerSpace\Scripts\EQ2Bot' locked
    sqlite[S8]: attempt to write a readonly database
    Additional errors:
    sqlite[S8]: attempt to write a readonly database
    Please execute the 'Cleanup' command.

    Then when i try the clean up command it tells me it failed due to the read only problem also.

    I have tried to go in to the folder and UN-click the read only box but it doesn't work.

    Thanks ahead of time for any help.
    Last edited: May 17, 2014
  4. Amadeus

    Amadeus The Maestro Staff Member

    The best thing might be to just rename your current directory, and redownload/recreate the directory completely. Then, you can copy over any custom files.
  5. Scoops

    Scoops Active Member

    It's likely a permissions issue. Either make sure you're an Administrator, or give yourself Full Control of that subdirectory (Properties -> Security tab in Windows Explorer).
  6. dnostrom

    dnostrom New Member

    Also make sure to restart your computer like the guide says.
  7. contra138

    contra138 Member

    This worked!

    Thanks guys for the reply!

Share This Page