Discussion in 'General Discussion' started by C@t@t0N1C, Aug 10, 2008.

  1. C@t@t0N1C

    C@t@t0N1C Active Member

    Messages:
    11
    After having just gone through the process of installing, configuring, and running, I thought I could provide a few pointers in addition to the instructions that might help those that read this avoid some of the pit-falls I found.

    1. You have to have Inner Space and ISXVG. This is pretty clear in the instructions.

    2. After you DL Inner Space you run the install. Then you have to execute the program for the first time so it can complete the install and check for updates. I'm fairly confident you have to do this before you move on to ISXVG.

    3. The instructions and installation for ISXVG are fairly straight-forward.

    4. The configuration of ISXVG seems to have one now-unnecessary step. There is already a default profile for Vanguard. It's "Vanguard: Saga of Heros"--you don't need to create another. Simply modify the existing one.

    Now for the tricky stuff.

    If you need instructions to repeat the configuration of ISXVG, you will need the URL -
    http://www.isxgames.com/isxvg/Setup_Step1.html

    Troubleshooting suggestion: I experienced a crash attempting to launch Vanguard (following the setup instructions). With assistance from both Lax and Amadeus I first removed the "Load ISXVG" command from the startup sequence. When I did that (how to put it in is covered in the Setup--just reverse the process) Inner Space launched successfully with Vanguard. I spoke with Amadeus, I was given a new ISXVG.dll that resolved the problem. I've since tested on a second system and had the exact same problem and resolved it using the updated dll.

    ** Important Note ** I forgot to do this on my first system, the first time. Before you run Inner Space for the very first time, start Vanguard and switch to windowed mode. You can do this with alt-enter or click Setup and then turn off the full screen mode. After you have done this, then follow the instructions on launching Vanguard using Inner Space. This saves you problems with the authentication challenge. Again, only the first time you launch Vg from within Inner Space. After that, it's however you like to play--full screen or windowed.



    Instructions for acquiring VGCraft are found here: http://www.isxgames.com/forums/showthread.php?t=3085

    Follow the instructions.

    VGCraft tips -

    Carefully read the post on mapping, " Moving and Mapping with VGCraft," which can be found at http://www.isxgames.com/forums/showthread.php?t=1314
    ** Notice this is important enough that I provided the URL ** You need to understand how to setup movement because when you do it right, it *rocks*


    Prog. Ratio, Min Qual, Max Qual.

    Prog. Ratio - this controls the decision-point on station progress vs. quality. Slide to the left to focus more on station progress. This means the more you move the slider to the left the more the bot will choose actions that give station progress (with less- or no quality). Slide to the right for more quality actions. This means the bot will choose quality actions over station-only actions but only until you hit the "Max Qual" slider.

    Min Qual - when quality falls below the variable set by this slider, the bot will aggressively choose quality actions regardless of the Prog Ratio slider position.

    Max Qual - when quality falls above the variable set by this slider, the bot will stop choosing quality actions and solely focus on station progress actions to finish the recipe.

    Batch of Dusky Softwood Brush, Hairs
    If you search forums you'll see a post on this. Watch the text posted by the bot. Because of the comma in this recipe you will see
    "VG: Recipe: NULL :: 3500 :: 8"
    As best I can tell this means the recipe cannot be identified and categorized (VEasy, Easy, Mod, Diff) by the bot. Just watch and wait. I don't think there's anything you can do with this.

    You should normally see text posted to your chat by the bot that looks something like:
    "VG: Recipe: Easy :: 3500 :: 8"
    This means the bot knows the recipe and the difficulty.

    Finally, the last thing I noticed--I was watching the bot flip through recipes and return to the NPC without crafting anything. I couldn't figure out why for some time. Then I spotted it. I had turned off the automatic table setup in the Vg client UI. I was trying to figure out why my table was double-stocking the main ingredient (like 2 stacks of Solvent, rather than 1). I *think* this is because it cannot determine that the stack is complete and this is a safety protocol. Anway, when I turned off the auto table setup it stopped loading specialty ingredients required by some recipes (Adhesive, Treatment, Emery, etc.). I don't have all of those configured under items--the table simply doesn't provide enough space. I turned the auto table setup back on and resolved this problem.

    Throughout this entire process I noticed starting could sometimes be challenging. Here's what I do to start:
    1. I'm always standing in front of the crafting table before I run the vgcraftbot script (launching the script)
    2. I'm always standing in front of the crafting table before I start the bot (starting the bot crafting).
    3. If the bot runs away from the table there is usually a reason. First check your item inventory. Frequently, letting the bot have it's reins is a good thing.
    4. If the bot is running and you really are sure it should be standing in front of the crafting table, sometimes you can prod it in the right direction by manually starting the recipe and then resuming.
    5. Sometimes you really just have to quit and re-launch the bot.
    6. I suspect most of this is user error. The reason I suspect this is the more I work with the bot, the less I need to provide "corrective action" -- great work, Xeon!!!

    I hope someone finds value and an easier experience in reading this.



    Added by Amadeus -- February 3, 2009
    You may also want to download and play around with one of these other scripts that are commonly used by ISXVG users:
    VGA - http://www.isxgames.com/forums/showthread.php?t=3078
    Fishing Assist Bot - http://www.isxgames.com/forums/showthread.php?t=3022

    There are also some other random older scripts found in this forum http://www.isxgames.com/forums/forumdisplay.php?f=23. Some of them still work and are at least "maintained", such as kbot.
  2. BigOleDick

    BigOleDick Active Member

    Messages:
    11
    I did. Nice work.


    Do you have something like this for the diplo bot?
  3. viliden

    viliden Active Member

    Messages:
    10
    nicely done sir.

    I've run dip bot a few times and generally my rule of thumb is keep the npc's pretty close, the script doesn't much care for a whole lot of running. Sometimes it makes bad choices if you pick an npc that is roaming and will want to dry hump a wall so try to avoid those. Unfortunatly the way diplomacy works now is you can only do parleys with npc's +5 levels on you so it kinda limits what you can do with it in certain areas. You kinda need to have atleast 3 npc's in the area to parley with in order to keep busy the whole time. Other then that just path your npc's out and sit back and enjoy the diplownage! hehe.
  4. C@t@t0N1C

    C@t@t0N1C Active Member

    Messages:
    11
    Thank you very much.

    Sorry, I've not done anything with diplo at all. If I dig into it, I'll be happy to post.
  5. C@t@t0N1C

    C@t@t0N1C Active Member

    Messages:
    11
    Update: I just noticed I didn't post that I discovered the double-stocking option. Yes, it's an option. Under the "Options" tab there is an option to "Load Extra Ingredients at Table Setup." If that's checked it'll double-stock your main ingredient. You can turn this off if you like--I prefer to leave it on. I have discovered there is one instance when it does not double-stock (when it should). I haven't isolated it, yet, as it is infrequent and appears to be random. It may be a long time before I discover any more detail around this so please feel free to post if you see something I missed.

Share This Page