StarDogs StatGen

Stardog

Active Member
Talk about it here.
Right now it shows.
Standard DPS
SKill/Spell DPS
Total DPS

Mobs Killed
hits taken
Hits givin
Damage taken
Damage givin by weapon, skill and spell
time to kill a mob
parries.
blocks

if you want something added post here, get me in IRC or mail me at
isxStardog@gmail.com
Or if you know me good enough, IM me or call me ;)
 

djvj

Active Member
Very cool.

My fps drops from 30 to 5 when I run it though. When Using diplobot it only drops like 2. So it's not that its a .net app trying to take focus. And yes the game does have focus.
 

Akku

Active Member
Dont works for me, getting every second this msg in the console
CombatSatsNeedUpdating = False and CombatInProgress = True
 

Smyrk

Active Member
Been trying to get this to run for me on my monk for a bit, but even with the system pretty well clean of running processes I keep getting the console spammed with:
Code:
 CombatStatsNeedUpdating = False and CombatInProgress = True
Additionally, I see this error:
Code:
Exception during event execution: System.FormatException: Input string was not in a correct format.
   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
   at System.Number.ParseInt64(String value, NumberStyles options, NumberFormatInfo numfmt)
   at Statgen.VGEvents.vgevent_IncomingCombatText(Object sender, LSEventArgs e)
   at Vanguard.ISXVG.VGEvent.OnIncomingCombatText(Object Sender, LSEventArgs e)
   at LavishScriptAPI.LavishScript.Events.Event.Target(Int32 argc, UInt32 argvToken, Int32 ThisObject)
Hopefully it helps you track down what is going on.
 

Malstrom

Active Member
Downloaded the file statgen.exe, tried running it and both times it crashed giving an error.

A window comes up saying it wants to send data to microsoft for error reporting.
EventType : clr20r3 P1 : statgen.exe P2 : 1.0.0.0 P3 : 46620c11
P4 : statgen P5 : 1.0.0.0 P6 : 46620c11 P7 : 2 P8 : 0
P9 : system.io.filenotfoundexception

Oops, just realized I needed to run it from the console. Newb mistake.

Now the problem is it just doesn't update. The console spams:
CombatStatsNeedUpdating = False CombatInProgress = False

Then when I start fighting it does recognize, but doesn't update anything.
CombatStatsNeedUpdating = False CombatInProgress = True

All stats stay at zero.
 
Last edited:

Stardog

Active Member
Weird. it should work. You are typing
dotnet statgen in the console?

I haven't been keeping that up, I actualy jsut use the Meleebot Kill button now. to generate that for me.
 
Top Bottom