Discussion in 'OgreBot' started by blackee, Jan 23, 2011.

  1. blackee

    blackee Senior Member

    Messages:
    246
    Cut through wall of text: Ogrebot isn't closing combat after short fights. Toons are stay in autoattack and don't resume follow.

    Wall of text: I am having an issue with my toons staying in auto-attack after fight is over. They won't AF after and i have to go to each screen and click the auto-attack button to start them up again.

    It happens more regularly when the fight is real short. For instance, i was killing single ups in JW and before my melee could attack, the mobs were dead. Then my melee toons wouldn't move. I tried adding something to eq2botcommander to set autoattack 0, but spent way too much time on something that did not work.

    Can a check if group has aggro, "if" statement be added to ogrebot?

    Thanks.
  2. Bishop97

    Bishop97 Active Member

    Messages:
    45
    On settings tab, click "turn off combat"
  3. blackee

    blackee Senior Member

    Messages:
    246
    sweet, will test and see if that fixes it! thanks for the quick reply! That has been a thorn since day one!
  4. Kannkor

    Kannkor Ogre

    Messages:
    3,615
    What Bishop97 said. What happens, is they turn attack on, and when your target dies, EQ2 is suppose to turn off your auto attack, but it doesn't always.

    Just don't use Turn Off ATtack on your tank, or you won't be able to "pre-ward".
  5. wolfppo

    wolfppo Active Member

    Messages:
    323
    Easy fix but have to do it every time it happens is if your using Ogrebot use the Master control program or w/e its called to activate it use this

    "Ogre OgreMCP" and once it is up under combat hit "no target" and the toon will stop auto atack and return to the start position.

    Also you could join some people on irc and ask there.
    http://www.isxgames.com/irc.php?nick=&chan=ISXEQ2&submit=Connect+to+IRC
  6. Kannkor

    Kannkor Ogre

    Messages:
    3,615
    I personally would just use "Turn Off Attack" then it's all automated... Your solution will work fine, but seems like more extra work when there is an option that does exactly that.
  7. wolfppo

    wolfppo Active Member

    Messages:
    323
    Oh ok lol Ill use that also ty K.
  8. blackee

    blackee Senior Member

    Messages:
    246
    Should have posted that the 2nd poster's post, worked. Toggle combat off and I am G2G.

    Different question: How do i reduce the distance on pull during auto hunt? I am getting stuck when the MT can't see mob.
  9. Kannkor

    Kannkor Ogre

    Messages:
    3,615
    Currently the distance is based on whatever ability you put in the drop down boxes, up to a max of 50 ISXEQ2 meters (which is different than 50 in game meters... but close enough for comparison).
  10. blackee

    blackee Senior Member

    Messages:
    246
    Is that hard coded or can i mod it? Otherwise, i'll just pick something (CA) with a short range.
  11. Kannkor

    Kannkor Ogre

    Messages:
    3,615
    The max of 50 is hardcoded I believe. It's something I keep meaning to expose to the UI but I haven't yet.

Share This Page