Discussion in 'EVEBot' started by antonsdp1985, Feb 2, 2013.

  1. antonsdp1985

    antonsdp1985 Member

    Messages:
    1
    Does anyone know how to stop "TriggerHARDSTOP called by fleetmate" its really annoying. It caused the miner to go back to the docking station. Seems to happen a lot.

    Pls Advise me on this.
  2. sergeydsn

    sergeydsn Member

    Messages:
    1
    The same problem "TriggerHARDSTOP called by fleetmate", and sometimes writes "Mining lasers not found" but they are set.
  3. mastercloudxxiv

    mastercloudxxiv Member

    Messages:
    2
    i am having this same issue, it works with one toon for the most part, havent tested long enough, but as soon as i uses 2 or more (i want to use all 9 ) it gets triggerhardstop called by fleetmate. how do we fix?
  4. n1439

    n1439 Member

    Messages:
    4
    +1 same problem
  5. titboy

    titboy Member

    Messages:
    2
    Hi there, i just registered and i have been playing around with Evebot for about 1 day now, and i also started to get this.
    So after 2 fresh installations of innerspace/isxeve/evebot and any combination there of i started to try to debug the code.

    Ended up at line 157 in the obj_miner.iss
    Being

    Code (Text):

    ;    If we're in space and HARD STOP has been called for, try to get to a station
            if ${EVEBot.ReturnToStation} && !${Me.InStation}
          {
                    This.CurrentState:Set["HARDSTOP"]
                return
         }
     
    In my understanding this basicly means that on Pulse in evebot this will be checked and my believe is that this is wrong.
    Even thou ${EVEBot.ReturnToStation} is true, ${Me.InStation} will be false for as long as your travelling towards the station for every Pulse triggered since the ReturnToStation.
    Looking at the codecomment, to my understanding it is as if the Hardstop is called for before the if expression, althou there is no check for it.

    I have made a quick and simple/ugly fix for this, which is just to comment the This.CurrentState:Set["HARDSTOP"] out, so it will not get triggered.
    Then it will look like this:
    Code (Text):

    ;    If we're in space and HARD STOP has been called for, try to get to a station
            if ${EVEBot.ReturnToStation} && !${Me.InStation}
            {
                 UI:UpdateConsole["UglyFix: Ignoring HARDSTOP called from line 159"]
                ;This.CurrentState:Set["HARDSTOP"]
                return
            }
     
    Althou this is not a proper solution, as this would infact problably get you into trouble in certain situations, but this is good enough for my small tasks.
    I would recommend that within this if expression should better logicalchecks on if we are actually travelling towards the stations something like


    Code (Text):

    if charging_warpdrive/aligning, do notthing and wait for next pulse
    if warping, do notthing and wait for next pulse
    if docking, do notthing and wait for next pulse
    if slow_poking_it_almost_at_station, do notthing and wait for next pulse
    I have not yet been really thorough looking through the documentation available so i am not sure if my suggested solution is possible or if it is the right one.
  6. sirbuthed

    sirbuthed Active Member

    Messages:
    16
    Well i dont think editing the script is the the right idea . From what i have seen the reason you get the hard stop is basically because you have somthing set wrong or there is a legitament reason that the bot called the hard stop . I'm also assuming that your usig the miner bot and more than one box at a time . so my suggestion is simple start one box and check that your bookmark for the drop off location is set correctly , make sure you are 100% repaired , then start one box and watch it for a full cycle to make sure it is working properly . if not you can ussually determine the problem from the main tab where it shows all the debugging info . also make sure when you are docked that you have your inventory open and the ore bay is the current tab or it will cause a continuous cyle of docking , not being able to find the ore , undocking and docking again .

    again i really wouldnt suggest working around the code and removing the hard stop . seems it was put there to keep your bots from doing stupid shit that could get you caught .

    Hope this helps :)
  7. Jagamata

    Jagamata Member

    Messages:
    29
    If still anybody has problems with the mining bot - here is a solution for it:
    First of all - it has to do with the new window system while inventory is opened docked or undocked. The bot is not opening the ore inventory of the mining ship for unloading.
    Secondly - if you are in space and starting the bot while the "ore hold" inventory and "normal inventory" is NOT open, than the bot is docking (TriggerHARDSTOP called by fleetmate).
    Solution:
    First press ESC and go into the “Shortcuts” TAB and assign here in “Window” a free shortcut key to “Open Ore Hold Of Active Ship”.
    Then click on the "Reset Settings" TAB. Reset there "Reset to Default Window Positions" (I know it is a little work to get it back but necessary)!
    After you closed the ESC-Window close all reset windows and make sure that you are on your mining ship. Than open with shortcut your “Open Inventory” AND open with shortcut key your “Open Ore Hold Of Active Ship”. Position both and click on "Ore Hold" in both windows. Do this undocked and docked and let the appearing windows open. After everything is set undock and dock again to make sure both windows stay open. After undocking load your mining bot while in space – fly to your mining place and click run – now everything should work fine. :rolleyes:
  8. BlabmBlabm

    BlabmBlabm Member

    Messages:
    2
    I have still the undocking and dock problem, doesnt helped.

    update: oh forgott to write, that it worked :D sometimes helps a evebot reload (close it and run evebot again) but the reply #5 is necceccary.
    Last edited: Mar 22, 2013
  9. slither

    slither Member

    Messages:
    1
    I'm also having this problem... I tried reconfiguring my windows as suggested earlier in this post, but it only worked for one round. Any more suggestions?
  10. valera

    valera New Member

    Messages:
    3
    So, going to last station doesn't seem to work properly if you just leave it blank, when I deleted Null it said error warping to r...anyhow whatever


    Resolution:

    You have to actually bookmark the station itself, and the name in the station name should match it exactly
    Right click station, save location, i removed the (station) bracket, then copy the name from the save location dialogue to the evebot box and magic happens
    kracazol likes this.
  11. aChallenged1

    aChallenged1 Active Member

    Messages:
    206
    Ignore #5 it's just not necessary.

    What you actually must do is open the inventory to the ore hold while docked and leave it open. Then undock and open it there, too; leaving it open. Then, to be sure, dock and see that it stays open, same with undocking. Once this is done (both instances the ore hold stays open) you can start the bot, provided you have bookmarked your station for delivery properly.

    #10 is right about the book mark, and what to do. "Yankee Station I - Moon IV (Station)" is not the same as "Yankee Station I - Moon IV". So, copy the name from the bookmark and paste it into the "location name" window in the "Miner" tab.

    In a way, it's all been said before. I simply like to put it all together in one post and make it as simple and clear as I can. I hope this helps.
  12. kracazol

    kracazol New Member

    Messages:
    3
    ^^^ This ^^^

    You are a Legend

Share This Page