Discussion in 'Scripts (LavishScript)' started by duken666, Sep 10, 2012.

  1. duken666

    duken666 Active Member

    Messages:
    29
    Hi, I'm using Vga to multibox but for some reason my cleric doesn't rebuff once the time has expired on the buffs. I added all the required spells into the buff section but nothing happens...

    Is it bugged or am I doing something wrong?

    Thx
  2. locutus71

    locutus71 Active Member

    Messages:
    13
    Same thing is happening to me....
  3. Amadeus

    Amadeus The Maestro Staff Member

    Messages:
    8,264
    Probably going to need more information from someone that can investigate the script and see exactly what's failing. I'm pretty busy for the next week or so, but I'll try to look at it if I have time. However, I could probably fix it quickly if I knew exactly what in isxvg was broken.
  4. duken666

    duken666 Active Member

    Messages:
    29
    I'd love to answer this question but I honestly don't know. All i know is that it did buff in the past (2 years ago) but now it doesn't. Perhaps it can't keep track of the current used buffs?

    Would be nice if you could take a look at it as buffs are very important to have...

    Thx :D
  5. Amadeus

    Amadeus The Maestro Staff Member

    Messages:
    8,264
    Is this still a problem after today's patch? I tested VGA myself and it rebuffed me when I removed my buffs.
  6. Verdict

    Verdict Member

    Messages:
    7
    Yes the problem is still occurring ....i just tried it on my sharman. VGA still will not follow as well
  7. Amadeus

    Amadeus The Maestro Staff Member

    Messages:
    8,264
    Someone is going to have to tell me how to recreate this problem with the buffing. I used a shaman myself and as soon as I cancel the buffs, it casts them back immediately.
  8. duken666

    duken666 Active Member

    Messages:
    29
    I use a Cleric and with the cleric it wont work. Perhaps it's a class based bug? Do you have access to a cleric to check? If not I can hook you up with access to mine.

    I use the standard installation of VGA, nothing is modified.
  9. Amadeus

    Amadeus The Maestro Staff Member

    Messages:
    8,264
    What exactly is happening though. If you have the ability in the UI set to be cast..it's just not casting? Was it working before and suddenly stopped? Is it only happening when the buff runs out by itself?

    I need a lot more information. Everything in this thread is very vague.
  10. duken666

    duken666 Active Member

    Messages:
    29
    I played around a little bit and I think i have it narrowed down.

    1st.) When the cleric is not in a group and Tank/Assist/Follow is set to himself the buffing works perfectly fine.

    2nd.) However when I group him up with my tank, he stops buffing. Even if I leave Tank/Assist/Follow the way it was without supplying the tanks name. The fact that he's in a group messes up things.

    3rd) I tried this: I set the Tank/Assist/Follow name of my tank and just dident group the cleric and the buffing worked again.

    So no group = works fine but with group = bug

    I have no idea what exactly is wrong though. Must be some wrong variable or something.

    I run two instances of VG on the same desktop just so you know my setup. The tank uses Kbot and my cleric uses VGA.

    Try this and let me know if you can reproduce the bug.
    Last edited: Sep 14, 2012
  11. Amadeus

    Amadeus The Maestro Staff Member

    Messages:
    8,264
    Is anything related to grouping bugged? This bug just started randomly a while back or did it never work for you?

    It may require waiting until the script author returns unless I see what's wrong with ISXVG.
  12. duken666

    duken666 Active Member

    Messages:
    29
    No idea honestly. I haven't played for 2-3 years. I just came back and well since then it diden't work.

    It's just the buffing that is bugged, all other assist and combat abilities work in group.

    Perhaps someone else can give you a better answer to this question.

    I'm not even sure if the author will return, which is a pitty as VGA is really great but no buffing is a major issue.

    If it is a VGA or isxvg problem is unclear. However I would guess it's VGA that has a small bug. Perhaps some variable got renamed or something. I do remember that VGA did work perfectly fine few years ago.

    Any chance you can dive into the code and take a look? Perhaps you'll see what the issue might be.

    Thx
  13. Amadeus

    Amadeus The Maestro Staff Member

    Messages:
    8,264
    You're absolutely sure you're using the latest version from SVN, right?
  14. duken666

    duken666 Active Member

    Messages:
    29
    Uhmm yes... does buffing work for you in a group?
  15. Verdict

    Verdict Member

    Messages:
    7
    The buffing was not working at all in group or single for me. It would do one buff and if that wasnt the all in one it would stop. The combat commands were not functioning unless you manually selected a target. This was as of last week. I havent tried it since then but will when I come back from vacation Monday.
  16. Tearlow

    Tearlow Member

    Messages:
    19
    I'am looking into this myself and I know the issue just not made a solution yet. Hopefully soon I can post one though.

    @Amadeus: I've never worked with SVN's before (Committing) should I send the changes to you once they're done or could you let me know how to submit them?
    Last edited: Oct 4, 2012
  17. Vertigo 7

    Vertigo 7 Member

    Messages:
    3
    I'm new here so take what I say with a grain of salt. I just got VGA a few hours ago, first time ive ever used it... followed the directions in the release thread, svn updated etc etc, and like people previously posted, group buffing is borked for my cleric as well (though I suspect its borked for any class).
    Anyway, I'm not a coder or script writer, nor do I wish to be so yeah, anyway...
    Code (Text):

    Act_Buff.iss
    function BuffUp()
    {
     if ${Group.Count} < 2
     call solobuff
     if ${Group.Count} > 1 && ${GroupStatus.Alive} && ${GroupStatus.AOEBuffClose} && ${GroupNeedsBuffs}
     call groupbuff
    }
     
    in this section of the script, i removed the {GroupNeedsBuffs} and magically my cleric starts group buffing like a pro.
    section now reads for me:
    Code (Text):

    function BuffUp()
    {
     if ${Group.Count} < 2
     call solobuff
     if ${Group.Count} > 1 && ${GroupStatus.Alive} && ${GroupStatus.AOEBuffClose}
     call groupbuff
    }
     
    I donno what that does but w/e, its working now, mostly. Only thing is that Renewal (single target buff) is only being cast on her. I donno how to make it cast on the rest of the group. Anyway, if someone with the know how could take a look and see what you can do, we would much appreciate it.

    *edit
    also it looks like the buff button only activates the first buff in the list and wont cycle through them all.
    Last edited: Oct 14, 2012
  18. Amadeus

    Amadeus The Maestro Staff Member

    Messages:
    8,264
    I just looked through VGA, and as far as I can tell, the script is designed so that the group buffing only occurs when someone is rezzed, or the group changes (someone adds/drops, etc.)

    So, if you have all of your buffs set up correctly in the UI, then invite someone to your group, it doesn't do the buffing at least once?

    I have a level 12 shaman to test with. If someone sends me screenshots of the UI setup with a level 12 shaman so I can see the bug I'll look into it.

Share This Page